<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>See you soon, West Chester - The Rocket</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.theonlinerocket.com/xmlrpc.php" />
    
<!-- Author Meta Tags by Molongui Authorship, visit: https://wordpress.org/plugins/molongui-authorship/ -->
<meta name="author" content="Tyler Howe">
<!-- /Molongui Authorship -->

<meta name='robots' content='max-image-preview:large' />
<meta property="og:image" content="https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-scaled.jpg" />
<!-- This site is optimized with the Yoast SEO plugin v12.9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="See you soon, West Chester - The Rocket" />
<meta property="og:description" content="Coming into the season, Rock football head coach Shawn Lutz knew that in the first two games of the season he would figure out what this team’s identity was going to be. In their first game, they showed what they can be. They rolled over Wayne State in a 42-10 rout. This Saturday they’ll get &hellip;" />
<meta property="og:url" content="https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/" />
<meta property="og:site_name" content="The Rocket" />
<meta property="article:section" content="Sports" />
<meta property="article:published_time" content="2022-09-09T20:42:18+00:00" />
<meta property="og:image" content="https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-1024x683.jpg" />
<meta property="og:image:secure_url" content="https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-1024x683.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="683" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Coming into the season, Rock football head coach Shawn Lutz knew that in the first two games of the season he would figure out what this team’s identity was going to be. In their first game, they showed what they can be. They rolled over Wayne State in a 42-10 rout. This Saturday they’ll get [&hellip;]" />
<meta name="twitter:title" content="See you soon, West Chester - The Rocket" />
<meta name="twitter:image" content="https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-scaled.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.theonlinerocket.com/#website","url":"https://www.theonlinerocket.com/","name":"The Rocket","description":"Slippery Rock University Newspaper","potentialAction":{"@type":"SearchAction","target":"https://www.theonlinerocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/#primaryimage","url":"https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-scaled.jpg","width":2560,"height":1707},{"@type":"WebPage","@id":"https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/#webpage","url":"https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/","inLanguage":"en-US","name":"See you soon, West Chester - The Rocket","isPartOf":{"@id":"https://www.theonlinerocket.com/#website"},"primaryImageOfPage":{"@id":"https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/#primaryimage"},"datePublished":"2022-09-09T20:42:18+00:00","dateModified":"2022-09-09T20:42:18+00:00","author":{"@id":"https://www.theonlinerocket.com/#/schema/person/c8903a8e08472de98d32120cf7d35243"}},{"@type":["Person"],"@id":"https://www.theonlinerocket.com/#/schema/person/c8903a8e08472de98d32120cf7d35243","name":"Tyler Howe","image":{"@type":"ImageObject","@id":"https://www.theonlinerocket.com/#authorlogo","url":"https://secure.gravatar.com/avatar/6a1eb31138f93292ba24811058583b1d?s=96&d=mm&r=g","caption":"Tyler Howe"},"description":"Tyler is a junior communication major with a concentration in converged journalism. He\u2019s in his third year with Rocket and it\u2019s his second semester as assistant sports editor. Through his first two years, he wrote nearly 70 articles. The majority of which have been for the sports section, but he has also written for campus life.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Rocket &raquo; Feed" href="https://www.theonlinerocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Rocket &raquo; Comments Feed" href="https://www.theonlinerocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Rocket &raquo; See you soon, West Chester Comments Feed" href="https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.theonlinerocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sbi_styles-css'  href='https://www.theonlinerocket.com/wp-content/plugins/instagram-feed/css/sbi-styles.min.css?ver=6.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.theonlinerocket.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='flytedesk-digital-css'  href='https://www.theonlinerocket.com/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101' type='text/css' media='all' />
<link rel='stylesheet' id='media-credit-css'  href='https://www.theonlinerocket.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='adamlabsgallery-plugin-settings-css'  href='https://www.theonlinerocket.com/wp-content/plugins/photo-gallery-portfolio/com/public/assets/css/settings.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='adamlabs-open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%2C800&#038;ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='adamlabs-raleway-css'  href='https://fonts.googleapis.com/css?family=Raleway%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='adamlabs-droid-serif-css'  href='https://fonts.googleapis.com/css?family=Droid+Serif%3A400%2C700&#038;ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='adamlabs-fontello-css'  href='https://www.theonlinerocket.com/wp-content/plugins/photo-gallery-portfolio/com/public/assets/font/fontello/css/fontello.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://www.theonlinerocket.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.4.8' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.theonlinerocket.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.theonlinerocket.com/wp-content/themes/Newspaper/style.css?ver=9.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-child-css'  href='https://www.theonlinerocket.com/wp-content/themes/Newspaper-child/style.css?ver=9.0.1c' type='text/css' media='all' />
<script type='text/javascript' id='flytedesk-digital-js-extra'>
/* <![CDATA[ */
var flytedesk_digital_publisher = {"uuid":"8b831196-b7d8-4597-885c-29a75f8a8419"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101' id='flytedesk-digital-js'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.4.8' id='tp-tools-js'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.4.8' id='revmin-js'></script>
<link rel="https://api.w.org/" href="https://www.theonlinerocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.theonlinerocket.com/wp-json/wp/v2/posts/39083" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.theonlinerocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.theonlinerocket.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.theonlinerocket.com/?p=39083' />
<link rel="alternate" type="application/json+oembed" href="https://www.theonlinerocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theonlinerocket.com%2Fsports%2F2022%2F09%2F09%2Fsee-you-soon-west-chester%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.theonlinerocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theonlinerocket.com%2Fsports%2F2022%2F09%2F09%2Fsee-you-soon-west-chester%2F&#038;format=xml" />
        <style>
            .molongui-disabled-link
            {
                border-bottom: none !important;
                text-decoration: none !important;
                color: inherit !important;
                cursor: inherit !important;
            }
            .molongui-disabled-link:hover,
            .molongui-disabled-link:hover span
            {
                border-bottom: none !important;
                text-decoration: none !important;
                color: inherit !important;
                cursor: inherit !important;
            }
        </style>
        <script type="text/javascript">
(function (w, d, s, p) {
  let f = d.getElementsByTagName(s)[0], j = d.createElement(s);
  j.id = 'flytedigital';
  j.async = true;
  j.src = 'https://digital.flytedesk.com/js/head.js#' + p;
  f.parentNode.insertBefore(j, f);
})(window, document, 'script', '8b831196-b7d8-4597-885c-29a75f8a8419');
</script>

<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    <meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.theonlinerocket.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.4.8 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />

<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://www.theonlinerocket.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.theonlinerocket.com/category/sports/",
                                "name": "Sports"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/",
                                "name": "See you soon, West Chester"                                
                            }
                        }    ]
                        }
                       </script><link rel="icon" href="https://www.theonlinerocket.com/wp-content/uploads/2019/09/cropped-rocket-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.theonlinerocket.com/wp-content/uploads/2019/09/cropped-rocket-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.theonlinerocket.com/wp-content/uploads/2019/09/cropped-rocket-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.theonlinerocket.com/wp-content/uploads/2019/09/cropped-rocket-270x270.jpg" />
<script type="text/javascript">function setREVStartSize(e){									
						try{ e.c=jQuery(e.c);var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;
							if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
						}catch(d){console.log("Failure at Presize of Slider:"+d)}						
					};</script>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	
</head>

<body data-rsssl=1 class="post-template-default single single-post postid-39083 single-format-standard see-you-soon-west-chester global-block-template-1 wpb-js-composer js-comp-ver-5.5.1 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/SRURocket" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/srurocket/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/SRURocket" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/user/TheSRURocket" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-31429" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-31429"><a href="https://www.theonlinerocket.com/category/news/">News</a></li>
<li id="menu-item-31430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31430"><a href="https://www.theonlinerocket.com/category/opinion/">Opinion</a></li>
<li id="menu-item-31428" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31428"><a href="https://www.theonlinerocket.com/category/sports/">Sports</a></li>
<li id="menu-item-31427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31427"><a href="https://www.theonlinerocket.com/category/campus-life/">Campus Life</a></li>
<li id="menu-item-31431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31431"><a href="https://www.theonlinerocket.com/category/multimedia/">Multimedia</a></li>
<li id="menu-item-37115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37115"><a href="https://www.theonlinerocket.com/category/digital-editions/">Digital Editions</a></li>
<li id="menu-item-31433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31433"><a href="https://www.theonlinerocket.com/advertising/">Advertising</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.theonlinerocket.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10 ">
    
	<div class="td-header-top-menu-full td-container-wrap ">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-2">
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/SRURocket" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/srurocket/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/SRURocket" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/user/TheSRURocket" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>        
<div class="td-header-sp-top-menu">


	<!-- td weather source: cache -->		<div class="td-weather-top-widget" id="td_top_weather_uid">
			<i class="td-icons clear-sky-d"></i>
			<div class="td-weather-now" data-block-uid="td_top_weather_uid">
				<span class="td-big-degrees">79.9</span>
				<span class="td-weather-unit">F</span>
			</div>
			<div class="td-weather-header">
				<div class="td-weather-city">Slippery Rock</div>
			</div>
		</div>
		        <div class="td_data_time">
            <div >

                Friday, September 9, 2022
            </div>
        </div>
    <div class="menu-top-container"><ul id="menu-td-demo-top-menu" class="top-header-menu"><li id="menu-item-33086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-33086"><a href="https://www.theonlinerocket.com/about/">About Us</a></li>
<li id="menu-item-33560" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-33560"><a href="https://www.theonlinerocket.com/editorial-policy/">Editorial Policy</a></li>
<li id="menu-item-31471" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-31471"><a href="https://www.theonlinerocket.com/meet-the-staff/">Meet The Staff</a></li>
<li id="menu-item-33087" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-33087"><a href="https://www.theonlinerocket.com/feedback/">Contact Us</a></li>
<li id="menu-item-33092" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-33092"><a href="https://www.theonlinerocket.com/contributor-form/">Join Our Team</a></li>
</ul></div></div>
    </div>

<!-- LOGIN MODAL -->
		</div>
	</div>

    <div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
        <div class="td-header-sp-logo">
            			<a class="td-main-logo" href="https://www.theonlinerocket.com/">
				<img src="https://www.theonlinerocket.com/wp-content/uploads/2018/11/Banner2-2.png" alt=""/>
				<span class="td-visual-hidden">The Rocket</span>
			</a>
		        </div>
    </div>

	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-header" href="https://www.theonlinerocket.com/">
			<img src="https://rocket.position.systems/wp-content/uploads/2018/11/Banner2-1.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="https://www.theonlinerocket.com/">
			<img src="https://www.theonlinerocket.com/wp-content/uploads/2018/11/Banner2-2.png" alt=""/>
		</a>
	    </div>
    <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-31429"><a href="https://www.theonlinerocket.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-31430"><a href="https://www.theonlinerocket.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-31428"><a href="https://www.theonlinerocket.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-31427"><a href="https://www.theonlinerocket.com/category/campus-life/">Campus Life</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-31431"><a href="https://www.theonlinerocket.com/category/multimedia/">Multimedia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-37115"><a href="https://www.theonlinerocket.com/category/digital-editions/">Digital Editions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-31433"><a href="https://www.theonlinerocket.com/advertising/">Advertising</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://www.theonlinerocket.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
			</div>
		</div>
	</div>

    
</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.theonlinerocket.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Sports" class="entry-crumb" href="https://www.theonlinerocket.com/category/sports/">Sports</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">See you soon, West Chester</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-39083" class="post-39083 post type-post status-publish format-standard has-post-thumbnail hentry category-sports" itemscope itemtype="https://schema.org/Article">

        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  style="background-color:#5c69c1; color:#fff; border-color:#5c69c1;" href="https://www.theonlinerocket.com/category/sports/">Sports</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">See you soon, West Chester</h1>

                

                <div class="td-module-meta-info">
                                            Published by <a href="/author/TylerH">Tyler Howe</a>,
                                                                                
                                        Date: September 9, 2022                    <div class="td-post-comments"><a href="https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/#respond"><i class="td-icon-comments"></i>0</a></div>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-39083">2</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-padding td-ps-big td-ps-nogap td-post-sharing-style13 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theonlinerocket.com%2Fsports%2F2022%2F09%2F09%2Fsee-you-soon-west-chester%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=See+you+soon%2C+West+Chester&url=https%3A%2F%2Fwww.theonlinerocket.com%2Fsports%2F2022%2F09%2F09%2Fsee-you-soon-west-chester%2F&via=The+Rocket">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><a href="https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-scaled.jpg" data-caption=""><img width="696" height="464" class="entry-thumb td-modal-image" src="https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-696x464.jpg" srcset="https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-696x464.jpg 696w, https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-300x200.jpg 300w, https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-1024x683.jpg 1024w, https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-768x512.jpg 768w, https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-1536x1024.jpg 1536w, https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-2048x1365.jpg 2048w, https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-1068x712.jpg 1068w, https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-630x420.jpg 630w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="_M6I7435"/></a></div>
        <p>Coming into the season, Rock football head coach Shawn Lutz knew that in the first two games of the season he would figure out what this team’s identity was going to be. In their first game, they showed what they can be. They rolled over Wayne State in a 42-10 rout.</p>
<p>This Saturday they’ll get the chance to prove that winning is their identity when they travel roughly 330 miles to West Chester for their first road game of the season.</p>
<p>“You really find out what you’re made of from week one into week two, you really find your identity,” Lutz said. “You find out what you’re all about, and the most improvement has got to be from week one to week two, so I expect us to get better in a lot of different ways.”</p>
<p>Against Wayne State, The Rock saw the emergence of a lot of new players. But there were also some familiar faces making plays. One of which was Cohen Russell, who made his return to Slippery Rock this season after spending one away.</p>
<p>After the game, Russell explained why he came back to The Rock in the first place, and if you ask around the locker room, it’s quite likely that you’ll get an answer very close to his.</p>
<p>“The family atmosphere [is what made me come back], at my last JUCO I could say it was more of a me, me, me instead of being a team and a family,” Russell said. “So when coach Lutz and coach [Adam] Neugebauer came to my house to recruit me, it was all about family and making sure I do the right thing in school.”</p>
<p>Neugebauer, who departed this past offseason, helped bring Russell back after he coached him in 2019. Russell showed up in The Rock’s season opener, and it couldn’t have gone any better for him. He had two receptions for 82 yards and two touchdowns to go along with a 58-yard kick return and 37-yard punt return. Both of which set up touchdown drives.</p>
<p>Russell joins newcomer Jacob Odom, who put up eight receptions for 97 yards in his Rock debut, and the veteran, Kyle Sheets, who posted three receptions for 37 yards and a touchdown on the receiving core.</p>
<p>“We don’t want to have one guy, we got some guys that can do a lot of a different things and I think it makes us a lot more multiple that we have other guys step up,” Lutz said. “I think it makes our offense a lot more explosive and I think having an experienced quarterback like Noah Grover really helps as well.”</p>
<p>The core is basically brand new to Grover, but throughout the offseason their chemistry was built, and it showed last Saturday. That can only be helped by a long trip.</p>
<p>“I like it that we’re going on the road because you get an opportunity to bond, and you leave on Friday and stay overnight and you kind of get closer as a team,” Lutz said. “We did what we needed to do [last week], but this West Chester team is going to be a lot different and historically they’ve been the best team in the East.”</p>
<p>It’s been just four years since West Chester walked into Slippery Rock and outplayed The Rock for the PSAC title. So, Lutz knows this team very well. That was the teams’ last meeting. This time the teams will play at Farrell Stadium.</p>
<p>“You really find out what you’re made of from week one into week two, you really find your identity,” Lutz said. “You find out what you’re all about, and the most improvement has got to be from week one to week two, so I expect us to get better in a lot of different ways.”</p>
<p>The rushing attack that consisted of Tim Smith, Chris D’Or, Isiah Edwards, Grover and Chris Wells showed up last week as well. The game may have been Slippery Rock’s most rounded game offensively in a while.</p>
<p>“Last year we didn’t run the ball good enough, and if we’re going to have a good offense, we need to be multiple, so now people have to choose between helping in the pass game or putting more people in the box to stop the run,” Lutz said. “We have a multitude of guys that can get the job done [at the running back position], and it also helps to have an experienced offensive line.”</p>
<p>The green and white will lean heavily on their rushing offense that put up 132 yards on 27 attempts last week. But they’ll be playing a defense that allowed only 269 total yards last week in a gritty battle against Bentley University. The Golden Rams pulled out a close 17-16 win.</p>
<p>The Rock’s defense also comes in off of an impressive performance. Slipper Rock held Wayne State’s ground game to 137 yards on 40 attempts. Something that they’ll need to do this week again.</p>
<p>“I think Wayne State runs the football and they play bully ball, and we held our own in that challenge, and it’ll be the same thing against West Chester,” Lutz said. “They have a big running back that reminds of Wes Hills, another guy who’s pretty good and their quarterback likes to run, so the key at West Chester is to tackle these running backs and stop the run, and if we can do that, I like our chances to win this football game.”</p>
<p>Phil Poquie put up 92 yards on the ground last week for West Chester and to Lutz the ability to stop him could make the difference between a win or a loss.</p>
<p>Slippery Rock’s only aspect of their game that didn’t play well last week was their special teams.</p>
<p>“Kickoff team wasn’t good enough and we missed two field goals, we just have to make those and have better protection on that,” Lutz said. “We’ve got to make big plays on the special team’s unit and play the field position.”</p>
<p>Lutz also wants the team to limit penalties. In their opening game, they committed 10 penalties for 79 yards. They’ll have to limit any penalties in order to walk out of West Chester with a win on Saturday afternoon.</p>
<p>“I don’t like the penalties, it’s always been a concern here and something that the guys need to be smarter about and need clean up,” Lutz said.</p>
<p>Well, the season did just start, every game in college football is huge. A loss at any point in the season could be the reason you don’t make the playoffs. California (Pa.), whose only loss was to Slippery Rock on the road last season, didn’t make the playoffs just last year. The significance of each game isn’t lost, especially to Lutz.</p>
<p>“If look at our schedule and ask us to circle a game, West Chester is definitely a game we’d circle, they’ve had their coach there for a long time and they got great guys on their football team,” Lutz said. “I think we can go on run if we find a way to win this game, it’s a must win.”</p>
<div class="td-a-rec td-a-rec-id-content_bottom  td_uid_1_631ba58f2eeaf_rand td_block_template_1"><div class="td-all-devices"><a href="#" target="_blank"><img src="https://ccnow.position.systems/wp-content/uploads/2018/09/newspaper-rec728.jpg"/></a></div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-padding td-ps-big td-ps-nogap td-post-sharing-style13 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theonlinerocket.com%2Fsports%2F2022%2F09%2F09%2Fsee-you-soon-west-chester%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=See+you+soon%2C+West+Chester&url=https%3A%2F%2Fwww.theonlinerocket.com%2Fsports%2F2022%2F09%2F09%2Fsee-you-soon-west-chester%2F&via=The+Rocket">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.theonlinerocket.com/partnered-content/2022/09/09/the-best-snacks-to-take-with-you-on-a-road-trip/">The Best Snacks To Take With You on a Road Trip</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="author-box-wrap"><a href="https://www.theonlinerocket.com/author/tylerh/"><img src="https://www.theonlinerocket.com/wp-content/uploads/2021/09/AZ1I7122-150x150.jpg" width="96" height="96" alt="Tyler Howe" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.theonlinerocket.com/author/tylerh/">Tyler Howe</a></span></div><div class="td-author-description">Tyler is a junior communication major with a concentration in converged journalism. He’s in his third year with Rocket and it’s his second semester as assistant sports editor. Through his first two years, he wrote nearly 70 articles. The majority of which have been for the sports section, but he has also written for campus life.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Tyler Howe"></span><meta itemprop="datePublished" content="2022-09-09T20:42:18+00:00"><meta itemprop="dateModified" content="2022-09-09T20:42:18+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.theonlinerocket.com/sports/2022/09/09/see-you-soon-west-chester/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.theonlinerocket.com/wp-content/uploads/2018/11/Banner2-2.png"></span><meta itemprop="name" content="The Rocket"></span><meta itemprop="headline " content="See you soon, West Chester"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.theonlinerocket.com/wp-content/uploads/2022/09/M6I7435-scaled.jpg"><meta itemprop="width" content="2560"><meta itemprop="height" content="1707"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_2_631ba58f3288b_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_2_631ba58f3288b" ><script>var block_td_uid_2_631ba58f3288b = new tdBlock();
block_td_uid_2_631ba58f3288b.id = "td_uid_2_631ba58f3288b";
block_td_uid_2_631ba58f3288b.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_2_631ba58f3288b_rand","td_column_number":3,"live_filter_cur_post_id":39083,"live_filter_cur_post_author":"33","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_2_631ba58f3288b_rand","tdc_css_class_style":"td_uid_2_631ba58f3288b_rand_style"}';
block_td_uid_2_631ba58f3288b.td_column_number = "3";
block_td_uid_2_631ba58f3288b.block_type = "td_block_related_posts";
block_td_uid_2_631ba58f3288b.post_count = "3";
block_td_uid_2_631ba58f3288b.found_posts = "2263";
block_td_uid_2_631ba58f3288b.header_color = "";
block_td_uid_2_631ba58f3288b.ajax_pagination_infinite_stop = "";
block_td_uid_2_631ba58f3288b.max_num_pages = "755";
tdBlocksArray.push(block_td_uid_2_631ba58f3288b);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_3_631ba58f35b1c" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_2_631ba58f3288b" href="#">RELATED ARTICLES</a><a id="td_uid_4_631ba58f35b1f" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_2_631ba58f3288b" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_2_631ba58f3288b class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.theonlinerocket.com/featured/2022/09/02/ready-for-round-three/" rel="bookmark" class="td-image-wrap" title="Ready for round three"><img width="218" height="150" class="entry-thumb" src="https://www.theonlinerocket.com/wp-content/uploads/2019/09/Sports-Thumbnail-218x150.jpg" srcset="https://www.theonlinerocket.com/wp-content/uploads/2019/09/Sports-Thumbnail-218x150.jpg 218w, https://www.theonlinerocket.com/wp-content/uploads/2019/09/Sports-Thumbnail-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Ready for round three"/></a></div>                <a href="https://www.theonlinerocket.com/category/sports/" class="td-post-category">Sports</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.theonlinerocket.com/featured/2022/09/02/ready-for-round-three/" rel="bookmark" title="Ready for round three">Ready for round three</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.theonlinerocket.com/sports/2022/08/30/new-faces-same-expectations/" rel="bookmark" class="td-image-wrap" title="New faces, same expectations"><img width="218" height="150" class="entry-thumb" src="https://www.theonlinerocket.com/wp-content/themes/Newspaper/images/no-thumb/td_218x150.png" alt=""/></a></div>                <a href="https://www.theonlinerocket.com/category/sports/" class="td-post-category">Sports</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.theonlinerocket.com/sports/2022/08/30/new-faces-same-expectations/" rel="bookmark" title="New faces, same expectations">New faces, same expectations</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.theonlinerocket.com/sports/2022/04/28/the-rock-heats-up/" rel="bookmark" class="td-image-wrap" title="The Rock heats up"><img width="218" height="150" class="entry-thumb" src="https://www.theonlinerocket.com/wp-content/uploads/2022/04/thumbnail_IMG_5338-218x150.jpg" srcset="https://www.theonlinerocket.com/wp-content/uploads/2022/04/thumbnail_IMG_5338-218x150.jpg 218w, https://www.theonlinerocket.com/wp-content/uploads/2022/04/thumbnail_IMG_5338-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The Rock heats up"/></a></div>                <a href="https://www.theonlinerocket.com/category/sports/" class="td-post-category">Sports</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.theonlinerocket.com/sports/2022/04/28/the-rock-heats-up/" rel="bookmark" title="The Rock heats up">The Rock heats up</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_631ba58f3288b" data-td_block_id="td_uid_2_631ba58f3288b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_631ba58f3288b" data-td_block_id="td_uid_2_631ba58f3288b"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/sports/2022/09/09/see-you-soon-west-chester/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.theonlinerocket.com/wp-comments-post.php?wpe-comment-post=therocket" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='39083' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td_block_wrap td_block_weather td_block_widget td_uid_5_631ba58f36f06_rand td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_5_631ba58f36f06" ><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Weather</span></h4></div><div id=td_uid_5_631ba58f36f06 class="td-weather-wrap td_block_inner td-column-1"><!-- td weather source: cache -->
		<div class="td-weather-header">
			<div class="td-weather-city">Slippery Rock</div>
			<div class="td-weather-condition">clear sky</div>
			<i class="td-location-icon td-icons-location" data-block-uid="td_uid_5_631ba58f36f06"></i>
		</div>

		<div class="td-weather-set-location">
			<form class="td-manual-location-form" action="#" data-block-uid="td_uid_5_631ba58f36f06">
				<input id="td_uid_5_631ba58f36f06" class="td-location-set-input" type="text"
					   name="location" value="">
				<label>enter location</label>
			</form>
		</div>

		<div class="td-weather-temperature">
			<div class="td-weather-temp-wrap">
				<div class="td-weather-animated-icon">
					<span
						class="td_animation_sprite-27-100-80-0-0-1 clear-sky-d td-w-today-icon"
						data-td-block-uid="td_uid_5_631ba58f36f06"></span>
				</div>
				<div class="td-weather-now" data-block-uid="td_uid_5_631ba58f36f06">
					<span class="td-big-degrees">79.9</span>
					<span class="td-circle">&deg;</span>
					<span class="td-weather-unit">F</span>
				</div>
				<div class="td-weather-lo-hi">
					<div class="td-weather-degrees-wrap">
						<i class="td-up-icon td-icons-arrows-up"></i>
						<span
							class="td-small-degrees td-w-high-temp">81.9</span>
						<span class="td-circle">&deg;</span>
					</div>
					<div class="td-weather-degrees-wrap">
						<i class="td-down-icon td-icons-arrows-down"></i>
						<span
							class="td-small-degrees td-w-low-temp">76.7</span>
						<span class="td-circle">&deg;</span>
					</div>
				</div>
			</div>
		</div>

		<div class="td-weather-info-wrap">
			<div class="td-weather-information">
				<div class="td-weather-section-1">
					<i class="td-icons-drop"></i>
					<span class="td-weather-parameter td-w-today-humidity">58						%</span>
				</div>
				<div class="td-weather-section-2">
					<i class="td-icons-wind"></i>
					<span
						class="td-weather-parameter td-w-today-wind-speed">0.8mph</span>
				</div>
				<div class="td-weather-section-3">
					<i class="td-icons-cloud"></i>
					<span class="td-weather-parameter td-w-today-clouds">0						%</span>
				</div>
			</div>


			<div class="td-weather-week">
									<div class="td-weather-days">
						<div class="td-day-0">Fri</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-0">80</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-1">Sat</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-1">78</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-2">Sun</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-2">68</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-3">Mon</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-3">68</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-4">Tue</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-4">66</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
								</div>
		</div>

		</div></div> <!-- ./block --><div class="td-a-rec td-a-rec-id-custom_ad_5  td_uid_6_631ba58f36fbd_rand td_block_template_1"><span class="td-adspot-title">- Advertisement -</span><div class="td-all-devices"><a href="#" target="_blank"><img src="https://rocket.position.systems/wp-content/uploads/2018/10/download2.jpg"/></a></div></div>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-13 ">
    <div class="td-container">
        <div class="td-pb-row">
            <div class="td-pb-span12">
                
                <div class="footer-social-wrap td-social-style-2">
                    
            <span class="td-social-icon-wrap">
                <a target="_blank" href="https://www.facebook.com/SRURocket" title="Facebook">
                    <i class="td-icon-font td-icon-facebook"></i>
                    <span class="td-social-name">Facebook</span>
                </a>
            </span>
            <span class="td-social-icon-wrap">
                <a target="_blank" href="https://www.instagram.com/srurocket/" title="Instagram">
                    <i class="td-icon-font td-icon-instagram"></i>
                    <span class="td-social-name">Instagram</span>
                </a>
            </span>
            <span class="td-social-icon-wrap">
                <a target="_blank" href="https://twitter.com/SRURocket" title="Twitter">
                    <i class="td-icon-font td-icon-twitter"></i>
                    <span class="td-social-name">Twitter</span>
                </a>
            </span>
            <span class="td-social-icon-wrap">
                <a target="_blank" href="https://www.youtube.com/user/TheSRURocket" title="Youtube">
                    <i class="td-icon-font td-icon-youtube"></i>
                    <span class="td-social-name">Youtube</span>
                </a>
            </span>                </div>
            </div>
        </div>
    </div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-33090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-33090"><a href="https://www.theonlinerocket.com/the-rocket-archives/">The Rocket Archives</a></li>
<li id="menu-item-33096" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-33096"><a href="https://www.theonlinerocket.com/the-rocket-awards/">Honors &#038; Awards</a></li>
<li id="menu-item-30610" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-30610"><a href="https://www.theonlinerocket.com/category/partnered-content/">Partnered Content</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Copyright 2019 The Rocket                </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.theonlinerocket.com/wp-admin/admin-ajax.php";
</script>
                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.theonlinerocket.com/sports/2012/01/27/big-shots-lead-to-victory-over-gannon/" rel="bookmark" class="td-image-wrap" title="Big shots lead to victory over Gannon"><img width="100" height="70" class="entry-thumb" src="https://www.theonlinerocket.com/wp-content/uploads/2013/01/1648655676-100x70.jpg" srcset="https://www.theonlinerocket.com/wp-content/uploads/2013/01/1648655676-100x70.jpg 100w, https://www.theonlinerocket.com/wp-content/uploads/2013/01/1648655676-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Big shots lead to victory over Gannon"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.theonlinerocket.com/sports/2012/01/27/big-shots-lead-to-victory-over-gannon/" rel="bookmark" title="Big shots lead to victory over Gannon">Big shots lead to victory over Gannon</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2012-01-27T11:03:28+00:00" >January 27, 2012</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.theonlinerocket.com/sports/2012/01/27/forgotten-angels-travel-to-haiti/" rel="bookmark" class="td-image-wrap" title="Forgotten Angels travel to Haiti"><img width="100" height="70" class="entry-thumb" src="https://www.theonlinerocket.com/wp-content/uploads/2013/01/403228624-100x70.png" srcset="https://www.theonlinerocket.com/wp-content/uploads/2013/01/403228624-100x70.png 100w, https://www.theonlinerocket.com/wp-content/uploads/2013/01/403228624-218x150.png 218w, https://www.theonlinerocket.com/wp-content/uploads/2013/01/403228624-540x385.png 540w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Forgotten Angels travel to Haiti"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.theonlinerocket.com/sports/2012/01/27/forgotten-angels-travel-to-haiti/" rel="bookmark" title="Forgotten Angels travel to Haiti">Forgotten Angels travel to Haiti</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2012-01-27T11:09:33+00:00" >January 27, 2012</time></span>                            </div>
        </div>

        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 9.0.1 (rara)
        Deploy mode: deploy
        
        uid: 631ba58f3db8e
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">

/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 1019px) and (max-width: 1140px) {
.td-header-wrap .td-header-menu-wrap-full, .td-header-wrap .td-header-menu-wrap, .td-header-wrap .td-header-main-menu {
    background-color: #ffffff !important;
}
#td-top-mobile-toggle i {
    color: #006f51;
}
.header-search-wrap .td-icon-search {
    color: #006f51 !important;
}
}


/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 768px) and (max-width: 1018px) {
.td-header-wrap .td-header-menu-wrap-full, .td-header-wrap .td-header-menu-wrap, .td-header-wrap .td-header-main-menu {
    background-color: #ffffff !important;
}
#td-top-mobile-toggle i {
    color: #006f51;
}
.header-search-wrap .td-icon-search {
    color: #006f51 !important;
}
}


/* custom responsive css from theme panel (Advanced CSS) */
@media (max-width: 767px) {
.td-header-wrap .td-header-menu-wrap-full, .td-header-wrap .td-header-menu-wrap, .td-header-wrap .td-header-main-menu {
    background-color: #ffffff !important;
}
#td-top-mobile-toggle i {
    color: #006f51;
}
.header-search-wrap .td-icon-search {
    color: #006f51 !important;
}
}
</style>

<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.0.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-includes/js/comment-reply.min.js?ver=6.0.2' id='comment-reply-js'></script>
<script id="molongui-authorship-front-inline-js-extra">var molongui_authorship_front_params = {"byline_prefix":"","byline_suffix":"","byline_separator":", ","byline_last_separator":" and ","byline_link_title":"View all posts by","byline_dom_tree":""};</script><script id="molongui-authorship-front-inline-js" type="text/javascript" data-file="front.16cd.min.js" data-version="4.6.12">var addBylineModifiers=function(){var r="?m_bm=true",e=document.querySelectorAll('a[href$="'+r+'"]');Array.prototype.forEach.call(e,function(e,t){e.setAttribute("href",decodeURIComponent(e.getAttribute("href")).replace(r,"")),e.insertAdjacentHTML("beforebegin",molongui_authorship_front_params.byline_prefix+" "),e.insertAdjacentHTML("afterend"," "+molongui_authorship_front_params.byline_suffix)})},decodeMultiAuthorBylines=function(){var e=document.querySelectorAll('a[href*="molongui_byline=true"]');Array.prototype.forEach.call(e,function(e,t){var r=e.getAttribute("href"),i=new URL(decodeURIComponent(r)),n=new URLSearchParams(i.search),a=i.origin,o=i.pathname,r="";if(!n.has("molongui_byline"))return!1;if(n.has("lang")&&(r="?lang="+n.get("lang")),""===e.innerText)return n.has("m_main_disabled")?e.removeAttribute("href"):e.setAttribute("href",a+o+r),!1;var l,s=[molongui_authorship_front_params.byline_separator,molongui_authorship_front_params.byline_last_separator],u=e.innerText.split(new RegExp(s.join("|"),"gi"));n.has("m_main_disabled")?(l=n.getAll("mca")).unshift("molongui-disabled-link"):(i=o.replace(/^\/|\/$/g,"").split("/").pop(),o.replace(/\/$/g,"").replace(i,""),(l=n.getAll("mca")).unshift(a+o+r));var d="",m=u.length,n=e.getAttribute("class"),a=e.getAttribute("target"),o=e.getAttribute("rel"),r=e.getAttribute("itemprop"),c=n?'class="'+n+'"':"",h=a?'target="'+a+'"':"",p=o?'rel="'+o+'"':"",f=r?'itemprop="'+r+'"':"";for(j=0;j<m;j++){var _=u[j].trim(),b="",b=""!==molongui_authorship_front_params.byline_dom_tree?molongui_authorship_front_params.byline_dom_tree.replace("{%ma_authorName}",_):_;"molongui-disabled-link"===l[j]||j>=l.length?d+=b:d+='<a href="'+l[j]+'" '+c+" "+p+" "+f+" "+h+' title="'+molongui_authorship_front_params.byline_link_title+" "+_+'">'+b+"</a>",j<m-1-1?d+=s[0]:j<m-1&&(d+=s[1])}e.insertAdjacentHTML("afterend",d),e.parentNode.removeChild(e)})},disableEmptyLinks=function(){var e=document.querySelectorAll('a[href="#molongui-disabled-link"]');Array.prototype.forEach.call(e,function(e,t){e.classList.add("molongui-disabled-link"),e.removeAttribute("href")})},initBylines=function(){addBylineModifiers(),decodeMultiAuthorBylines(),disableEmptyLinks()};document.addEventListener("DOMContentLoaded",function(){initBylines();var e=document.body;new MutationObserver(function(e){Array.prototype.forEach.call(e,function(e,t){initBylines()})}).observe(e,{attributes:!0,childList:!0,subtree:!0,characterData:!0})});</script>
<!-- JS generated by theme -->

<script>
    

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Slippery Rock","api_location":"Slippery Rock","api_language":"en","api_key":"b8d16a2d1d1f8e08b6f2623c16844763","today_icon":"clear-sky-d","today_icon_text":"clear sky","today_temp":[26.6,79.9],"today_humidity":58,"today_wind_speed":[1.3,0.8],"today_min":[24.8,76.7],"today_max":[27.7,81.9],"today_clouds":0,"current_unit":1,"forecast":[{"timestamp":1662757200,"day_name":"Fri","day_temp":[27,80],"owm_day_index":0},{"timestamp":1662768000,"day_name":"Sat","day_temp":[25,78],"owm_day_index":1},{"timestamp":1662854400,"day_name":"Sun","day_temp":[20,68],"owm_day_index":9},{"timestamp":1662940800,"day_name":"Mon","day_temp":[20,68],"owm_day_index":17},{"timestamp":1663027200,"day_name":"Tue","day_temp":[19,66],"owm_day_index":25},{"timestamp":1663113600,"day_name":"Wed","day_temp":[14,56],"owm_day_index":33}]});
				});
			
			

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_uid_5_631ba58f36f06","location":"Slippery Rock","api_location":"Slippery Rock","api_language":"en","api_key":"b8d16a2d1d1f8e08b6f2623c16844763","today_icon":"clear-sky-d","today_icon_text":"clear sky","today_temp":[26.6,79.9],"today_humidity":58,"today_wind_speed":[1.3,0.8],"today_min":[24.8,76.7],"today_max":[27.7,81.9],"today_clouds":0,"current_unit":1,"forecast":[{"timestamp":1662757200,"day_name":"Fri","day_temp":[27,80],"owm_day_index":0},{"timestamp":1662768000,"day_name":"Sat","day_temp":[25,78],"owm_day_index":1},{"timestamp":1662854400,"day_name":"Sun","day_temp":[20,68],"owm_day_index":9},{"timestamp":1662940800,"day_name":"Mon","day_temp":[20,68],"owm_day_index":17},{"timestamp":1663027200,"day_name":"Tue","day_temp":[19,66],"owm_day_index":25},{"timestamp":1663113600,"day_name":"Wed","day_temp":[14,56],"owm_day_index":33}]});
				});
			
			

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.theonlinerocket.com/wp-content/themes/Newspaper-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.theonlinerocket.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<div data-m-brand="Molongui" data-m-id="Authorship" data-m-license="Lite" data-m-version="4.6.12" data-m-link="https://www.molongui.com/authorship/"></div>
</body>
</html>