<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />
<meta name="generator" content="WordPress 4.9.8" />
<meta name="viewport" content="width=device-width,maximum-scale=1.0" />
			<script type="text/javascript">
			var addToHomeConfig = {
			expire: 10000,
			touchIcon: true
		};
		</script>
		<link rel="stylesheet" href="https://www.theonlinerocket.com/wp-content/themes/snoflex/tools/addtohome/add2home.css">
		<script type="application/javascript" src="https://www.theonlinerocket.com/wp-content/themes/snoflex/tools/addtohome/add2home.js"></script>
		<meta name="apple-mobile-web-app-capable" content="yes">
	<link rel="apple-touch-icon" href="https://www.theonlinerocket.com/wp-content/uploads/2014/02/TheRocket1.jpeg" /><link rel="Shortcut Icon" href="https://www.theonlinerocket.com/wp-content/uploads/2014/06/favicon1.ico" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The Rocket RSS 2.0" href="https://www.theonlinerocket.com/feed/" />
<link rel="alternate" type="text/xml" title="The Rocket RSS .92" href="https://www.theonlinerocket.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The Rocket Atom 0.3" href="https://www.theonlinerocket.com/feed/atom/" />
<link rel="pingback" href="https://www.theonlinerocket.com/xmlrpc.php" />


<title>Rock Around The Rock: Remembering Mac Miller &#8211; The Rocket</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Rocket &raquo; Rock Around The Rock: Remembering Mac Miller Comments Feed" href="https://www.theonlinerocket.com/campus-life/2018/09/28/rock-around-the-rock-remembering-mac-miller/feed/" />

<!-- This site uses the Google Analytics by MonsterInsights plugin v 6.2.8 - https://www.monsterinsights.com/ -->
<!-- Normally you will find the Google Analytics tracking code here, but the webmaster disabled your user group. -->
<!-- / Google Analytics by MonsterInsights -->

		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.theonlinerocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
		<style type="text/css">
				</style>
	<link rel='stylesheet' id='farbtastic-css'  href='https://www.theonlinerocket.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.theonlinerocket.com/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.theonlinerocket.com/wp-includes/js/thickbox/thickbox.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://www.theonlinerocket.com/wp-content/plugins/menu-icons/vendor/kucrut/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.theonlinerocket.com/wp-content/plugins/menu-icons/vendor/kucrut/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://www.theonlinerocket.com/wp-content/plugins/menu-icons/vendor/kucrut/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.theonlinerocket.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.11.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.theonlinerocket.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.8' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Arial%2C+sans-serif%3A400%2C700&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://www.theonlinerocket.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20180212' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://www.theonlinerocket.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://www.theonlinerocket.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://www.theonlinerocket.com/wp-content/themes/snoflex/style.css?ver=20180928' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://www.theonlinerocket.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.0.4' type='text/css' media='screen' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.theonlinerocket.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/jquery.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.theonlinerocket.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.theonlinerocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.theonlinerocket.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Women&#8217;s soccer falls to Seton Hill following back-to-back draws' href='https://www.theonlinerocket.com/sports/2018/09/28/womens-soccer-falls-to-seton-hill-following-back-to-back-draws/' />
<link rel='next' title='Rock draws with nationally ranked Seton Hill' href='https://www.theonlinerocket.com/sports/2018/09/28/rock-draws-with-nationally-ranked-seton-hill/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel="canonical" href="https://www.theonlinerocket.com/campus-life/2018/09/28/rock-around-the-rock-remembering-mac-miller/" />
<link rel='shortlink' href='https://www.theonlinerocket.com/?p=29027' />
<link rel="alternate" type="application/json+oembed" href="https://www.theonlinerocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theonlinerocket.com%2Fcampus-life%2F2018%2F09%2F28%2Frock-around-the-rock-remembering-mac-miller%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.theonlinerocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theonlinerocket.com%2Fcampus-life%2F2018%2F09%2F28%2Frock-around-the-rock-remembering-mac-miller%2F&#038;format=xml" />
<!-- Flytedesk Digital -->

<script type="text/javascript">

(function (w, d, s, p) {

let f = d.getElementsByTagName(s)[0], j = d.createElement(s);

j.id (http://j.id/) = 'flytedigital';

j.async = true;

j.src = 'https://digital.flytedesk.com/js/head.js#' + p;

f.parentNode.insertBefore(j, f);

})(window, document, 'script', '7ef73256-e693-4410-9c0d-ee4d9b78db1d');

</script>
<!-- End Flytedesk Digital -->    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 0px 0px 0px 0px;
            position: relative;
            z-index: 1000;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #55750C;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>

	<meta property="og:title" content="Rock Around The Rock: Remembering Mac Miller" />
	<meta property="og:type" content="article" />
	<meta name="author" content="Kathryn Kinder" />
	<meta property="og:url" content="https://www.theonlinerocket.com/campus-life/2018/09/28/rock-around-the-rock-remembering-mac-miller/" />
	<meta property="og:image" content="https://www.theonlinerocket.com/wp-content/uploads/2018/09/mac-miller-900x506.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="506" />
	<meta property="og:site_name" content="The Rocket" />
	<meta property="og:description" content="On September 7, 2018, the music industry lost a young artist whose music was the background score for many college students growing up. Malcolm James McCormick or Mac Miller, 26, was a Pittsburgh-born rapper. He grew up loving his hometown of Pittsburgh and in 2010, his dreams of becoming a rapper came true. He was..." />
	<meta name="description" content="On September 7, 2018, the music industry lost a young artist whose music was the background score for many college students growing up. Malcolm James McCormick or Mac Miller, 26, was a Pittsburgh-born rapper. He grew up loving his hometown of Pittsburgh and in 2010, his dreams of becoming a rapper came true. He was..." />
	<meta property="article:section" content="Campus Life" />
	<meta property="article:tag" content="" />
<!-- End of Facebook Meta Tags -->
<script src="/wp-content/themes/snoflex/parallax/js/skrollr.js"></script>

<script>
	$(document).ready(function() {
		var wpadminbar = $('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if ($('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
			
		
		
	
	});
</script>


<style type="text/css" media="screen">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</style>
</head>

<body data-rsssl=1>				<script type="text/javascript">
					$(document).ready(function() {
						$(".newsticker3-jcarousellite").jCarouselLite({
        					horizontal: true,
        					visible: 1,
        					auto:3000,
        					speed:2000    					});
					});
				</script><div class="topnavwrap">
	<div id="topnavbar">
			
			<div class="search-spacer"></div>

			<div class="topnavbarleft social-classic">
				<style>.topnavbarleft { padding: 0px; width:auto; }</style><a aria-hidden="true" target="_blank" href="https://www.theonlinerocket.com/feed/rss/"><div class="alt-header-social social-border sno-rss dashicons dashicons-rss"><span class="icon-hidden-text">RSS Feed</span></div></a><a aria-hidden="true" target="_blank" href="http://www.youtube.com/user/TheSRURocket">
        		<div class="alt-header-social-fa social-border sno-youtube fa fa-youtube"><span class="icon-hidden-text">YouTube</span></div>
        	</a><a aria-hidden="true" target="_blank" href="https://picasaweb.google.com/102411195724997861921?feat=flashalbum">
	       		<div class="alt-header-social-fa social-border sno-google-plus fa fa-google-plus"><span class="icon-hidden-text">Google Plus</span></div>
	        </a><a aria-hidden="true" target="_blank" href="http://instagram.com/srurocket">
        		<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"><span class="icon-hidden-text">Instagram</span></div>
        	</a><a aria-hidden="true" target="_blank" href="https://twitter.com/SRURocket">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a aria-hidden="true" target="_blank" href="https://www.facebook.com/SRURocket">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div>			</div>

			<div class="topnavbarcenter">
                    <script src="https://www.theonlinerocket.com/wp-content/themes/snoflex/javascript/date.js" type="text/javascript"></script>
        			</div>
	
			<div class="topnavbarright">
					<form method="get" id="searchform1188" action="https://www.theonlinerocket.com/">
			<label for="s1188" class="assistive-text">Search</label>
			<div class="search-button-container" id="searchthis1188">
			<button type="submit" disabled="disabled" id="sno-search-navbar-1188" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<input type="text" class="field s" name="s" id="s1188" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit1188" style="display:none;" value="Search" />
		</form>
				</div>
	</div>
	<div class="clear"></div>
</div><div id="sno_mobile_menu"><ul id="slidemenu" class="mobile-menu"><div class="sno-side-menu side-close-icon foundation-icons fi-x"><span class="icon-hidden-text">Close Menu</span></div><li class="mobile-search-side"><form method="get" id="searchform-alt-left" action="https://www.theonlinerocket.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" id="searchsubmit-left" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="menu"><ul>
<li class="page_item page-item-21208"><a href="https://www.theonlinerocket.com/apply-here/">2017 Staff Applications</a></li>
<li class="page_item page-item-24"><a href="https://www.theonlinerocket.com/staff/">2017-2018 Staff</a></li>
<li class="page_item page-item-25"><a href="https://www.theonlinerocket.com/about/">About</a></li>
<li class="page_item page-item-3489"><a href="https://www.theonlinerocket.com/advertising/">Advertising</a></li>
<li class="page_item page-item-8173"><a href="https://www.theonlinerocket.com/athlete-of-the-month/">Athlete of the Month</a></li>
<li class="page_item page-item-192"><a href="https://www.theonlinerocket.com/calendar/">Calendar</a></li>
<li class="page_item page-item-9924"><a href="https://www.theonlinerocket.com/classifieds/">Classifieds</a></li>
<li class="page_item page-item-6656"><a href="https://www.theonlinerocket.com/comics/">Comics</a></li>
<li class="page_item page-item-7164"><a href="https://www.theonlinerocket.com/feedback/">Contact Us</a></li>
<li class="page_item page-item-9486"><a href="https://www.theonlinerocket.com/contributor-form/">Contributor Form</a></li>
<li class="page_item page-item-27213"><a href="https://www.theonlinerocket.com/the-rocket-awards/">Honors &#038; Awards</a></li>
<li class="page_item page-item-182"><a href="https://www.theonlinerocket.com/pollsarchive/">pollsarchive</a></li>
<li class="page_item page-item-24803"><a href="https://www.theonlinerocket.com/the-rocket-archives/">The Rocket Archives</a></li>
<li class="page_item page-item-9779"><a href="https://www.theonlinerocket.com/job-descriptions/">The Rocket Staff Positions</a></li>
<li class="page_item page-item-24648 page_item_has_children"><a href="https://www.theonlinerocket.com/staff-info/">The Staff Page</a>
<ul class='children'>
	<li class="page_item page-item-24655"><a href="https://www.theonlinerocket.com/staff-info/staff-applications/">2018-2019 Staff Applications</a></li>
</ul>
</li>
</ul></div>
</ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://www.theonlinerocket.com/wp-content/uploads/2013/09/RocketMasthead-2013-480px.png" class="headerimage" alt="An Independent, Student-Run Newspaper at Slippery Rock University" /></div><div class="headerlink headermedium" style="display:none"><img src="https://www.theonlinerocket.com/wp-content/uploads/2013/09/RocketMasthead-2013-780px.png" class="headerimage" alt="An Independent, Student-Run Newspaper at Slippery Rock University" /></div><div class="headerlink headerlarge"><img src="https://www.theonlinerocket.com/wp-content/uploads/2014/10/Banner2.png" class="headerlink headerimage" alt="An Independent, Student-Run Newspaper at Slippery Rock University" /></div><h1 style="display:none">The Rocket</h1><script type="text/javascript">
						$(document).ready(function(){
							$(".headerlink").click(function(){
								window.location="https://www.theonlinerocket.com";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon dashicons dashicons-menu"><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://www.theonlinerocket.com"><img src="https://www.theonlinerocket.com/wp-content/uploads/2014/10/Banner2.png" class="headerimage" alt="An Independent, Student-Run Newspaper at Slippery Rock University" /></a></div><h1 style="display:none">The Rocket</h1></div></div><div class="navbarwrap"><div class="navbarcontainer"><div id="navbar"><div id="navbarbackground"><div id="menu-a-menu"><nav role="navigation" aria-label="Secondary Menu"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="sf-menu sno-top-menu"><li id="menu-item-176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-176"><a href="https://www.theonlinerocket.com/category/news/">News</a></li>
<li id="menu-item-175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-175"><a href="https://www.theonlinerocket.com/category/opinion/">Opinion</a></li>
<li id="menu-item-177" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-177"><a href="https://www.theonlinerocket.com/category/campus-life/">Campus Life</a></li>
<li id="menu-item-173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-173"><a href="https://www.theonlinerocket.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-25043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25043"><a href="https://www.theonlinerocket.com/category/sports/2017-sports-special/">2017 Sports Special</a></li>
	<li id="menu-item-8179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8179"><a href="https://www.theonlinerocket.com/athlete-of-the-month/">Athlete of the Month</a></li>
</ul>
</li>
<li id="menu-item-343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-343"><a href="https://www.theonlinerocket.com/category/multimedia/">Multimedia</a>
<ul class="sub-menu">
	<li id="menu-item-2097" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2097"><a href="https://www.theonlinerocket.com/category/photo-slideshows/">Photo Slideshows</a></li>
</ul>
</li>
<li id="menu-item-7718" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7718"><a href="https://www.theonlinerocket.com/advertising/">Advertising</a></li>
<li id="menu-item-7719" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7719"><a href="https://www.theonlinerocket.com/category/digital-editions/">Digital Editions</a></li>
<li id="menu-item-7721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-7721"><a href="https://www.theonlinerocket.com/about/">About Us</a>
<ul class="sub-menu">
	<li id="menu-item-7171" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7171"><a href="https://www.theonlinerocket.com/feedback/">Contact Us</a></li>
	<li id="menu-item-27216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27216"><a href="https://www.theonlinerocket.com/the-rocket-awards/">Honors &#038; Awards</a></li>
	<li id="menu-item-8380" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8380"><a href="https://www.theonlinerocket.com/staff-info">Staff</a></li>
	<li id="menu-item-24674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24674"><a href="https://www.theonlinerocket.com/contributor-form/">Contribute</a></li>
	<li id="menu-item-24808" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24808"><a href="https://www.theonlinerocket.com/the-rocket-archives/">The Archives</a></li>
</ul>
</li>
</ul></div></nav></div><ul id='menu-more-top' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-top" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
								<ul id="add-more-top" class="sub-menu"></ul>
								</li>
							</ul></div></div></div></div><div class="clear"></div>
					<script type="text/javascript">
						$('#navbar').css("overflow-y", "hidden");
						$(window).load(function() {
							if ($( window).width() < 980) { return; }	
							resizeMenuTop();
						})
												
						function resizeMenuTop() {
							
							if ($( window).width() < 980) { return; }
	
							var moreWidthTop = 0; var menubufferTop = 0; var minilogoTop = 0;
	
							if ($('#menu-more-top').is(':visible')) { moreWidthTop = $('#menu-more-top').width(); }			
																																				var MenuTopWidth = 970;
															var browserWidth = $(window).width();
								if (browserWidth < MenuTopWidth) MenuTopWidth = browserWidth;
								
							
							if ($('#menu-a-menu').width() + menubufferTop + minilogoTop + moreWidthTop >= MenuTopWidth) 
							{ 
								$('.sno-top-menu > li:last-child').addClass('sub-menu'); 
								$('.sno-top-menu > li:last-child').appendTo('#add-more-top'); 
								if ($('#menu-more-top').is(':hidden')) { $('#menu-more-top').css({display: "block"}); }			
								if ($('#menu-a-menu').width() + menubufferTop + minilogoTop + moreWidthTop > MenuTopWidth) {
									resizeMenuTop(); 
								} else {
									$('#navbar').css("overflow-y", "unset");
									resizeMenuTop(); 
								}
							} else {
								$('#navbar').css("overflow-y", "unset");								
							}
							 
						}
	            		$( window ).resize(function() { 
	             	   		if ($( window).width() > 980) { resizeMenuTop(); };
	            		});   
	 				</script>
	 			<div id="fullwrap" style="position:relative;"><div id="outerbackgroundwrap"><div class="innerbackgroundwrap"><div class="innerbackground"><div id='classic_story' class='sno-story-29027'><div id="content"><div id='contentleft'><div class="postarea"><h1 class="storyheadline">Rock Around The Rock: Remembering Mac Miller</h1><div class="photowrap"><a class='modal-photosingle29027' href='#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/09/mac-miller-900x506.jpg' alt='Photo+by+Alex+Mowrey' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photosingle29027 photo-enlarge elusive el-icon-zoom-in'></div><div class='remodal remodal-story-image' data-remodal-id='modal-photosingle29027' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close</span></button><div class='single-photo-container single-photo-containersingle29027'><img id="imagesingle29027" src="https://www.theonlinerocket.com/wp-content/uploads/2018/09/mac-miller.jpg" alt="Photo by Alex Mowrey" class="enlarged-photo" /></div><div class="caption-container"><p class='photocaptionremodal'>Photo by Alex Mowrey</p><p class='photocreditremodal'><p class="photocredit">Graphic by Megan Bush</p></p></div></div><script type="text/javascript">
												$(document).ready(function() {
													$(function(){
														$(".modal-photosingle29027").click(function() {
															var inst = $("[data-remodal-id=modal-photosingle29027]").remodal();
															inst.open();
															var slideshow_area_heightsingle29027 = $('.single-photo-container').height(); 
															var photo_heightsingle29027 = 675;
													
															if (photo_heightsingle29027 < slideshow_area_heightsingle29027 ) {
																var top_marginsingle29027 = (slideshow_area_heightsingle29027 - photo_heightsingle29027)/2;
																$('#imagesingle29027').css("margin-top", top_marginsingle29027);
															}
														});
													});
													$('.feature-image').hover(function(){
														$('.photo-enlarge').css("background", "#006F51");
													}, function(){
														$('.photo-enlarge').css("background", "none");
													});

												});
										</script></div><div class="clear"></div><div class="captionboxmittop"><p class="photocredit">Graphic by Megan Bush</p><p class="photocaption">Photo by Alex Mowrey</p></div><div class="clear"></div><div class="permalinkphotobox"></div><div class="storydetails"><p><span class="storybyline"> <a href="https://www.theonlinerocket.com/staff/?writer=Kathryn%20Kinder">Kathryn Kinder</a>, Rocket Contributor</span><br /><span class="storydate"><span class="time-wrapper">September 28, 2018</span></span></p></div><script type="text/javascript">
					$(function () {
						$('.commentscroll').click(function () {
						var adjustment = 70;
																		$('html, body').animate({ scrollTop: $("#commentswrap").offset().top - adjustment }, 500);
						return false;
						});
					});
				</script><div class="sharing sharing-top"><a class='commentscroll' href='https://www.theonlinerocket.com/campus-life/2018/09/28/rock-around-the-rock-remembering-mac-miller/#respond'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.theonlinerocket.com%2Fcampus-life%2F2018%2F09%2F28%2Frock-around-the-rock-remembering-mac-miller%2F" title="Share on Facebook" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Rock+Around+The+Rock%3A+Remembering+Mac+Miller&amp;url=https%3A%2F%2Fwww.theonlinerocket.com%2F%3Fp%3D29027" title="Tweet This Story" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a aria-hidden="true" data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a></div>			<script type="text/javascript">
				$(document).ready(function() {
					$(function(){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '29027';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $("#suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<label for="email_to_Above" style="display:none;">Send email to this address</label>
  				<input type="text" id="email_to_Above" name="email_to_Above" class="sno_email_fields" placeholder="Send email to this address"><br />
  				
  				<label for="email_from_Above" style="display:none;">Enter Your Name</label>
  				<input type="text" id="email_from_Above" name="email_from_Above" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				
  				<label for="email_comment_Above" style="display:none;">Add a comment here</label>
  				<textarea rows="4" id="email_comment_Above" name="email_comment_Above" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				
  				<label for="human_Above" style="display:none;">Verification</label>
  				<input type="text" id="human_Above" name="human_Above" class="sno_email_fields" placeholder="What's 6 + 6?"><br />

  				<br />
  				<button id="submit_email_Above" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form" name="sno_email_submission_form" value="f7b5704263" /><input type="hidden" name="_wp_http_referer" value="/campus-life/2018/09/28/rock-around-the-rock-remembering-mac-miller/" />
  				</form>
  				</div>
			</div>
										<script>
								$(document).ready(function() {

								$(function(){
           							$('#submit_email_Above').click(function(){
											var storyid = '29027';
											var datastring = '';
											if ($("#email_to_Above").length > 0){
												var email_to = $('input[name=email_to_Above]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Above").length > 0){
												var email_from = $('input[name=email_from_Above]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Above").length > 0){
												var email_comment = $('textarea[name=email_comment_Above]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Above").length > 0){
												var human = $('input[name=human_Above]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 12;

       										var verification = $('input[name=sno_email_submission_form]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $("#emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			<span class="storycontent"><p id='graph1'>On September 7, 2018, the music industry lost a young artist whose music was the background score for many college students growing up. Malcolm James McCormick or Mac Miller, 26, was a Pittsburgh-born rapper. He grew up loving his hometown of Pittsburgh and in 2010, his dreams of becoming a rapper came true. He was signed to his first record deal at a local Pittsburgh-indie record label called Rostrum Records.</p>
<p id='graph2'>Before he was even signed to a record deal, however, in 2007 at age fifteen, he released a mixtape called But My Mackin’ Ain’t Easy under the moniker of EZ Mac. It was the years between then to 2010 Miller would release two more mixtapes before being discovered by Rostrum Records.</p>
<p id='graph3'>Mac Miller dropped the mixtape, Best Day Ever, in 2010. This mixtape had hits songs such as &#8220;Wear My Hat&#8221; and &#8220;All Around The World.&#8221; Most notably, this mixtape featured hit single, &#8220;Donald Trump.&#8221; This song was Miller’s first Billboard Top 100 single, reaching number 75. In November 2010, Miller’s most memorable song, to most people, &#8220;Knock Knock,&#8221; was released. He was 18 when this song debuted.</p>
<p id='graph4'>Miller’s debut album in 2011 was dedicated to where he grew up. The album, titled Blue Slide Park after Frick Park in Squirrel Hill, helped launch Miller’s career and put him on the charts. The second song on the album was titled &#8220;Party on Fifth Ave.&#8221; This is a clear reference to Fifth Avenue in downtown Pittsburgh. And although it was not an official single, Miller’s song, &#8220;Smile Back,&#8221; became his highest-chart spot on the Billboard Top 100, reaching number 55.</p>
<p id='graph5'>In December 2012, Miller performed in SRU&#8217;s own Aebersold Recreational Center as one of University Program Board&#8217;s annual concerts. He proudly sported a Pittsburgh Pirates hat and performed after opening acts Mod Sun and The Come UP.</p>
<p id='graph6'>In his eight years of making music, Mac Miller had five studio albums, one live studio album, and had seven tours, with some being worldwide. He was also featured on the hit single &#8220;The Way&#8221; by Ariana Grande in 2013. After his passing, Frick Park held a memorial in his honor and re-painted the famous Blue Slide back to its original dark blue.</p>
<p id='graph7'>Mac Miller will truly be missed as an icon, inspiration and idol to many people, including those from Pittsburgh.</p>
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print(); return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/printfriendly-pdf-button.png" alt="Print Friendly, PDF & Email" /></a></div></p><div id="story_bottom"></div></span><div class="clear"></div><div class="postmeta"></div></div><script>
        		$(document).ready(function() {
    				$("#commentsbox").click(function() {
    			    	$("#commentsbody").slideToggle('slow');
    			    	$("#expand").toggle();
    			    	$("#collapse").toggle();
    				});
				});				
        		$(document).ready(function() {
    				$("#commentslink").click(function() {
    			    	$("#commentsbody").slideDown('slow');
    			    	$("#expand").hide();
    			    	$("#collapse").show();
    				});
				});				
			</script><div id="comments" class="sno-animate" style="height:60px;display:block"></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div id="expand"><div class="fa fa-plus-square"></div></div><div id="collapse"><div class="fa fa-minus-square"></div></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id="commentsbody" class="widgetbody">


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">

If you want a picture to show with your comment, go get a <a href="http://en.gravatar.com" >gravatar</a>.</p>



<p>You must be <a href="https://www.theonlinerocket.com/wp-login.php?redirect_to=https://www.theonlinerocket.com/campus-life/2018/09/28/rock-around-the-rock-remembering-mac-miller/">logged in</a> to post a comment.</p>







</div></div><div class="widgetfooter"></div></div></div></div><div id="sidebar"><div class="snoadnetwork"><div class="widgetwrap"><h3>Advertisement</h3><div class="widgetbody3"><div class="advertisementwrap" style="float:none;margin:0px auto;max-width:300px"><!-- Begin PublicityClerks Zone 2530 -->
<script type="text/javascript">
(function() {
var pubc = document.createElement('script'); 
pubc.type = 'text/javascript'; 
pubc.async = true;
pubc.src = '//cdn.publicityclerks.com/core/ad2/9672/2530';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(pubc, s);
})();
</script>
<div id="pubclerks_2530"></div>
<!-- End PublicityClerks Zone 2530 --></div></div></div></div><div class='widgetwrap sno-animate sno-sportsscore-6' style=''><div class="widget6 widgettitle" >Recent Sports Scores</div><div class="widgetbody6" style="">
							
						
			
				<script type="text/javascript">
					$(function() {
					$(".newsticker-jcarousellite6").jCarouselLite({
       						 vertical: true,
        					visible: 1,
        					auto: 3000,
        					speed:666,
							scroll: 1						    });
					});
				</script>
			
									
											
												  						    						 						           																                    							            							            							            							
									
										<div class="sportsscrollbox">

    									<div id="newsticker-demo6" style="width:320px">    
        								<div class="newsticker-jcarousellite6" style="width:320px">
        								<ul>
								                							<li>
                							<div class="sportsscore" style="width:320px;padding-top:8px;margin-bottom:8px;">
                    							<p>Saturday, September 29</p>
                    							<p>Women's Soccer (Home) 1:00 p.m.</p>
                    							                    								<p>SRU 0  - East Stroudsburg University  0</p>
                     							                    							</div>
                							<div class="clear"></div>
            								</li>
															    						 						           																                    							            							            							            							
								                							<li>
                							<div class="sportsscore" style="width:320px;padding-top:8px;margin-bottom:8px;">
                    							<p>Saturday, September 29</p>
                    							<p>Football (Home) Final</p>
                    							                    								<p>SRU 41  - Mercyhurst University  21</p>
                     							                    							</div>
                							<div class="clear"></div>
            								</li>
															    						 						           																                    							            							            							            							
								                							<li>
                							<div class="sportsscore" style="width:320px;padding-top:8px;margin-bottom:8px;">
                    							<p>Saturday, September 29</p>
                    							<p>Men's Soccer (Home) Final</p>
                    							                    								<p>SRU 1  - East Stroudsburg University  2</p>
                     							                    							</div>
                							<div class="clear"></div>
            								</li>
															    						 						           																                    							            							            							            							
								                							<li>
                							<div class="sportsscore" style="width:320px;padding-top:8px;margin-bottom:8px;">
                    							<p>Saturday, September 29</p>
                    							<p>Field Hockey (Away) Final</p>
                    							                    								<p>SRU 0  - No. 8 Bloomsburg University  1</p>
                     							                    							</div>
                							<div class="clear"></div>
            								</li>
															    						 						           																                    							            							            							            							
								                							<li>
                							<div class="sportsscore" style="width:320px;padding-top:8px;margin-bottom:8px;">
                    							<p>Saturday, September 29</p>
                    							<p>Women's Soccer (Home) Final</p>
                    							                    								<p>SRU 0  - East Stroudsburg  2</p>
                     							                    							</div>
                							<div class="clear"></div>
            								</li>
															    						 						           																                    							            							            							            							
								                							<li>
                							<div class="sportsscore" style="width:320px;padding-top:8px;margin-bottom:8px;">
                    							<p>Saturday, September 29</p>
                    							<p>Volleyball (Away) Final</p>
                    							                    								<p>SRU 0  - California University (Pa.) 3</p>
                     							                    							</div>
                							<div class="clear"></div>
            								</li>
															    						 						           																                    							            							            							            							
								                							<li>
                							<div class="sportsscore" style="width:320px;padding-top:8px;margin-bottom:8px;">
                    							<p>Saturday, September 29</p>
                    							<p>Tennis (Away) All Day</p>
                    							                    								<p>SRU 0  - PSAC Individual Championships  0</p>
                     							                    							</div>
                							<div class="clear"></div>
            								</li>
															  
  						
															</ul>
    								</div>
    								</div>
    								</div>

    							
		<div class="widget-expander" style="padding-bottom:"></div><div class="clear"></div>

			</div>
			
		
</div>
		
  	<div style="clear:both"></div><div class="widgetwrap sno-animate"><div></div><div class="titlewrap"><div class="widgettitle-nonsno">Polls</div></div><div class="widgetbody"><div id="polls-31" class="wp-polls">
		<p style="text-align: center;"><strong>Athlete of the Month - March</strong></p><div id="polls-31-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li>Emily Bitka - LAX <small>(13%, 186 Votes)</small><div class="pollbar" style="width: 13%;" title="Emily Bitka - LAX (13% | 186 Votes)"></div></li>
		<li>Carla Corrochano Moracho - Tennis <small>(44%, 644 Votes)</small><div class="pollbar" style="width: 44%;" title="Carla Corrochano Moracho - Tennis (44% | 644 Votes)"></div></li>
		<li>Courtney McQuaide - Track and Field <small>(1%, 15 Votes)</small><div class="pollbar" style="width: 1%;" title="Courtney McQuaide - Track and Field (1% | 15 Votes)"></div></li>
		<li>Kailey Myers - Softball <small>(26%, 372 Votes)</small><div class="pollbar" style="width: 26%;" title="Kailey Myers - Softball (26% | 372 Votes)"></div></li>
		<li>Christian Porterfield - Baseball <small>(16%, 232 Votes)</small><div class="pollbar" style="width: 16%;" title="Christian Porterfield - Baseball (16% | 232 Votes)"></div></li>
		</ul><p style="text-align: center;">Total Voters: <strong>1,449</strong></p></div>
		<input type="hidden" id="poll_31_nonce" name="wp-polls-nonce" value="9458376799" />
</div>
<div id="polls-31-loading" class="wp-polls-loading"><img src="https://www.theonlinerocket.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<ul><li><a href="/pollsarchive">Polls Archive</a></li></ul></div><div class="widgetfooter3"></div></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="dashicons dashicons-arrow-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span><span class="flex-prev"><div class="stb_left"><div class="dashicons dashicons-arrow-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://www.theonlinerocket.com/news/2018/09/25/sru-institutes-honors-college/#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/09/untitled1-475x356.png' id='grow-stb28937'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Rock Around The Rock: Remembering Mac Miller'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb28937').mouseenter(function() {
   											$('#grow-stb28937').removeClass('shrink');
   											$('#grow-stb28937').removeClass('grow');
   											$('#grow-stb28937').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb28937').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/news/2018/09/25/sru-institutes-honors-college/">SRU institutes Honors College</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.theonlinerocket.com/sports/2018/09/17/strong-goaltending-leads-rock-women-to-win-over-walsh-university/#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/09/wsoc-walsh-380x475.jpg' id='grow-stb28752'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Rock Around The Rock: Remembering Mac Miller'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb28752').mouseenter(function() {
   											$('#grow-stb28752').removeClass('shrink');
   											$('#grow-stb28752').removeClass('grow');
   											$('#grow-stb28752').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb28752').addClass('shrink');
   										});});</script><p class='stb-cat'>Showcase</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/sports/2018/09/17/strong-goaltending-leads-rock-women-to-win-over-walsh-university/">Strong goaltending leads Rock women to win over Walsh University</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.theonlinerocket.com/campus-life/2018/09/17/its-rocket-science-car-emissions-and-climate-change/#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/09/My-Post-1-475x267.jpg' id='grow-stb28741'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Rock Around The Rock: Remembering Mac Miller'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb28741').mouseenter(function() {
   											$('#grow-stb28741').removeClass('shrink');
   											$('#grow-stb28741').removeClass('grow');
   											$('#grow-stb28741').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb28741').addClass('shrink');
   										});});</script><p class='stb-cat'>Campus Life</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/campus-life/2018/09/17/its-rocket-science-car-emissions-and-climate-change/">It&#8217;s Rocket Science: Car Emissions and Climate Change</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.theonlinerocket.com/campus-life/2018/09/16/accounting-seniors-future-is-totally-accounted-for-after-receiving-scholarship/#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/09/Hannah-3-356x475.jpg' id='grow-stb28552'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Rock Around The Rock: Remembering Mac Miller'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb28552').mouseenter(function() {
   											$('#grow-stb28552').removeClass('shrink');
   											$('#grow-stb28552').removeClass('grow');
   											$('#grow-stb28552').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb28552').addClass('shrink');
   										});});</script><p class='stb-cat'>Campus Life</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/campus-life/2018/09/16/accounting-seniors-future-is-totally-accounted-for-after-receiving-scholarship/">Accounting senior&#8217;s future is totally &#8216;accounted&#8217; for after receiving scholarship</a></p></li><li class='stb-top-row'><p class='stb-cat'>Multimedia</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/news/2018/09/13/president-behre-delivers-his-first-state-of-the-university-address/">President Behre delivers his first State of the University Address</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.theonlinerocket.com/campus-life/2018/09/13/fraternity-and-sorority-life-organizations-serve-the-community-provide-positive-opportunities/#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/09/kappa-sig-475x317.jpg' id='grow-stb28554'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Rock Around The Rock: Remembering Mac Miller'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb28554').mouseenter(function() {
   											$('#grow-stb28554').removeClass('shrink');
   											$('#grow-stb28554').removeClass('grow');
   											$('#grow-stb28554').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb28554').addClass('shrink');
   										});});</script><p class='stb-cat'>Campus Life</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/campus-life/2018/09/13/fraternity-and-sorority-life-organizations-serve-the-community-provide-positive-opportunities/">Fraternity and Sorority Life organizations serve the community, provide positive opportunities</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.theonlinerocket.com/multimedia/2018/10/01/mens-soccer-vs-east-stroudsburg-university-photo-slideshow/#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/10/AM6I4422-475x317.jpg' id='grow-stb29116'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Rock Around The Rock: Remembering Mac Miller'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb29116').mouseenter(function() {
   											$('#grow-stb29116').removeClass('shrink');
   											$('#grow-stb29116').removeClass('grow');
   											$('#grow-stb29116').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb29116').addClass('shrink');
   										});});</script><p class='stb-cat'>Multimedia</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/multimedia/2018/10/01/mens-soccer-vs-east-stroudsburg-university-photo-slideshow/">Men&#8217;s Soccer vs. East Stroudsburg University | Photo Slideshow</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.theonlinerocket.com/multimedia/2018/10/01/rock-football-vs-mercyhurst-university-photo-slideshow/#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/10/AM6I4830-475x317.jpg' id='grow-stb29114'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Rock Around The Rock: Remembering Mac Miller'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb29114').mouseenter(function() {
   											$('#grow-stb29114').removeClass('shrink');
   											$('#grow-stb29114').removeClass('grow');
   											$('#grow-stb29114').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb29114').addClass('shrink');
   										});});</script><p class='stb-cat'>Multimedia</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/multimedia/2018/10/01/rock-football-vs-mercyhurst-university-photo-slideshow/">Rock Football vs Mercyhurst University | Photo Slideshow</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.theonlinerocket.com/sports/2018/09/29/wolfe-scores-game-winner-as-field-hockey-tops-mercyhurst/#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/09/FH-tuesday-475x317.jpeg' id='grow-stb29073'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Rock Around The Rock: Remembering Mac Miller'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb29073').mouseenter(function() {
   											$('#grow-stb29073').removeClass('shrink');
   											$('#grow-stb29073').removeClass('grow');
   											$('#grow-stb29073').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb29073').addClass('shrink');
   										});});</script><p class='stb-cat'>Sports</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/sports/2018/09/29/wolfe-scores-game-winner-as-field-hockey-tops-mercyhurst/">Wolfe scores game winner as field hockey tops Mercyhurst</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.theonlinerocket.com/news/2018/09/28/master-of-accountancy-proposed-for-fall-2019/#photo'><img src='https://www.theonlinerocket.com/wp-content/uploads/2018/09/MAcc-Graphic-475x342.jpg' id='grow-stb28989'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Rock Around The Rock: Remembering Mac Miller'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb28989').mouseenter(function() {
   											$('#grow-stb28989').removeClass('shrink');
   											$('#grow-stb28989').removeClass('grow');
   											$('#grow-stb28989').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb28989').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.theonlinerocket.com/news/2018/09/28/master-of-accountancy-proposed-for-fall-2019/">Master of Accountancy proposed for fall 2019</a></p></li></ul></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		$(document).ready(function() {
			$('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: $(".custom-navigation span"), 
       			slideshow: false,
				itemMargin: 1,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

  							//		animation: 'fade',
  							//		smoothHeight: false,
  							//		customDirectionNav: $("#sfi-navigation span"),
  							//		animationLoop: true,
  							//		slideshow: false,
  							//		touch: true



		});

			$(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			$(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if ($('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = $(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && $(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if ($('.sno_teaserbar').is(":hidden")) {
						$('.sno_teaserbar').show();
						$('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && $(document).scrollTop() > 500) || $(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					$('.sno_teaserbar').stop().animate({
						top: '-80px'
						},200, function(){
							$('.sno_teaserbar').hide();
						});
				} 
			});
								$('#sno_teaserbar').hover(function(){
				$('.stb_right').css("color", "#aaa");
				$('.stb_left').css("color", "#aaa");
				$('.stb_right').css("border-color", "#aaa");
				$('.stb_left').css("border-color", "#aaa");
				$('.stb_right').hover(function(){
					$('.stb_right').css("color", "#006F51");
					$('.stb_right').css("border-color", "#006F51");
				}, function(){
					$('.stb_right').css("color", "#aaa");
					$('.stb_right').css("border-color", "#aaa");
				})
				$('.stb_left').hover(function(){
					$('.stb_left').css("color", "#006F51");
					$('.stb_left').css("border-color", "#006F51");
				}, function(){
					$('.stb_left').css("color", "#aaa");
					$('.stb_left').css("border-color", "#aaa");
				})
			}, function(){
				$('.stb_right').css("color", "#ddd");
				$('.stb_left').css("color", "#ddd");
				$('.stb_right').css("border-color", "#ddd");
				$('.stb_left').css("border-color", "#ddd");
			})
		});
	</script></div></div></div></div><div style="clear:both;"></div><div class="footerwrap"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="https://www.theonlinerocket.com">The Rocket</a></p></div></div><div class="footertagline"><p>An Independent, Student-Run Newspaper at Slippery Rock University</p></div><div class="clear"></div><div class="footercredit"><p>&copy; 2018  &bull; <a target='_blank' href='https://snosites.com/client-site-privacy-policy/'>Privacy Policy</a> &bull; <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://www.theonlinerocket.com/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div><script type="text/javascript">
jQuery(window).load(function() {
	jQuery('.flexslider').animate({'opacity': 1}, { 'duration': 'slow'});
	jQuery('.flex-container').css('background', 'unset');
});

</script><script type="text/javascript">
// start of scroll to view


$(document).ready(function() {
	
	$("a[href='#slideshow']").on('click', function(event) { return false; });
	$("a[href='#photo']").on('click', function(event) { return false; });

var win = $(window);
var allMods = $(".sno-animate");
var allWPcaptions = $(".wp-caption");

// Already visible modules
allMods.each(function(i, el) {
  var el = $(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
else {
  /*  Like this!  */
  el.css('visibility', 'hidden');
  }
});
allWPcaptions.each(function(i, el) {
  var el = $(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
});


$(window).scroll(function(event) {
  
  $(".sno-animate").each(function(i, el) {
    var el = $(el);
    if (el.visible(true)) {
      	el.addClass("come-in");     
	    el.css('visibility', 'visible'); // Visible
    } 
  });
  $(".wp-caption").each(function(i, el) {
    var el = $(el);
    if (el.visible(true)) {
      	el.addClass("come-in");     
	    el.css('visibility', 'visible'); // Visible
    } 
  });
  
});


});
//end of scroll to view
</script>
<script type="text/javascript">
	$(function(){
		$(".s").focus(function(){
			$(".sno-submit-search-button").prop("disabled", false);
		});				
	});
    var top_level_links = $(".sf-menu").find('> li > a');
    // Set tabIndex to -1 so that top_level_links can't receive focus until menu is open
    $(top_level_links).next('ul')
        .attr({ 'aria-hidden': 'true', 'role': 'menu' })
        .find('a')
            .attr('tabIndex',-1);

    // Adding aria-haspopup for appropriate items
    $(top_level_links).each(function(){
        if($(this).next('ul').length > 0)
            $(this).parent('li').attr('aria-haspopup', 'true');
    });
   
jQuery( function() {
 	jQuery( '#hover-menu-side' ).on( 'touchstart click', function(e) {
 		e.preventDefault();
 			$('#sno_mobile_menu').fadeToggle();
		    $("body").toggleClass('noscroll');

 	});
 	jQuery( '.side-close-icon' ).on( 'touchstart click', function(e) {
 		e.preventDefault();
 			$('#sno_mobile_menu').fadeToggle();
			    $("body").toggleClass('noscroll');
 	});
 		
});

</script>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-31058813-22', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	      <script type="text/javascript">

          var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '1';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.theonlinerocket.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.theonlinerocket.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.8'></script>
<script type='text/javascript' src='https://www.theonlinerocket.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
</div><div id="sno_hoversearch"><div class="sno-search-close foundation-icons fi-x" style="float:right;"></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://www.theonlinerocket.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="hover-menu"><div class="sno-menu menu-icon dashicons dashicons-menu"><span class="icon-hidden-text">Menu</span></div><div class="sno-menu close-icon foundation-icons fi-x" style="display:none;"><span class="icon-hidden-text">Close Menu</span></div></div><div id="search-top"><div aria-hidden="true" class="sno-search-button fa fa-search"><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><script type="text/javascript">
					$(function () {
						$('.commentscroll').click(function () {
						var adjustment = 70;
																		$('html, body').animate({ scrollTop: $("#commentswrap").offset().top - adjustment }, 500);
						return false;
						});
					});
				</script><div class="sharing sharing-top"><a class='commentscroll' href='https://www.theonlinerocket.com/campus-life/2018/09/28/rock-around-the-rock-remembering-mac-miller/#respond'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.theonlinerocket.com%2Fcampus-life%2F2018%2F09%2F28%2Frock-around-the-rock-remembering-mac-miller%2F" title="Share on Facebook" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Rock+Around+The+Rock%3A+Remembering+Mac+Miller&amp;url=https%3A%2F%2Fwww.theonlinerocket.com%2F%3Fp%3D29027" title="Tweet This Story" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a aria-hidden="true" data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a></div>			<script type="text/javascript">
				$(document).ready(function() {
					$(function(){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '29027';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $("#suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<label for="email_to_Bar" style="display:none;">Send email to this address</label>
  				<input type="text" id="email_to_Bar" name="email_to_Bar" class="sno_email_fields" placeholder="Send email to this address"><br />
  				
  				<label for="email_from_Bar" style="display:none;">Enter Your Name</label>
  				<input type="text" id="email_from_Bar" name="email_from_Bar" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				
  				<label for="email_comment_Bar" style="display:none;">Add a comment here</label>
  				<textarea rows="4" id="email_comment_Bar" name="email_comment_Bar" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				
  				<label for="human_Bar" style="display:none;">Verification</label>
  				<input type="text" id="human_Bar" name="human_Bar" class="sno_email_fields" placeholder="What's 0 + 6?"><br />

  				<br />
  				<button id="submit_email_Bar" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form" name="sno_email_submission_form" value="f7b5704263" /><input type="hidden" name="_wp_http_referer" value="/campus-life/2018/09/28/rock-around-the-rock-remembering-mac-miller/" />
  				</form>
  				</div>
			</div>
										<script>
								$(document).ready(function() {

								$(function(){
           							$('#submit_email_Bar').click(function(){
											var storyid = '29027';
											var datastring = '';
											if ($("#email_to_Bar").length > 0){
												var email_to = $('input[name=email_to_Bar]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Bar").length > 0){
												var email_from = $('input[name=email_from_Bar]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Bar").length > 0){
												var email_comment = $('textarea[name=email_comment_Bar]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Bar").length > 0){
												var human = $('input[name=human_Bar]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 6;

       										var verification = $('input[name=sno_email_submission_form]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $("#emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			</div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div aria-hidden="true" class="sno-arrow-up fa fa-arrow-up"><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="https://www.theonlinerocket.com/wp-content/uploads/2013/09/RocketMasthead-2013-480px.png" alt="An Independent, Student-Run Newspaper at Slippery Rock University" /></a></div><div class="hover_title"><div class="hover_titletext">Rock Around The Rock: Remembering Mac Miller</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul id="slidemenu" class="mobile-menu"><li class="mobile-search"><form method="get" id="searchform-alt-left" action="https://www.theonlinerocket.com/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" id="searchsubmit-left" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="menu"><ul>
<li class="page_item page-item-21208"><a href="https://www.theonlinerocket.com/apply-here/">2017 Staff Applications</a></li>
<li class="page_item page-item-24"><a href="https://www.theonlinerocket.com/staff/">2017-2018 Staff</a></li>
<li class="page_item page-item-25"><a href="https://www.theonlinerocket.com/about/">About</a></li>
<li class="page_item page-item-3489"><a href="https://www.theonlinerocket.com/advertising/">Advertising</a></li>
<li class="page_item page-item-8173"><a href="https://www.theonlinerocket.com/athlete-of-the-month/">Athlete of the Month</a></li>
<li class="page_item page-item-192"><a href="https://www.theonlinerocket.com/calendar/">Calendar</a></li>
<li class="page_item page-item-9924"><a href="https://www.theonlinerocket.com/classifieds/">Classifieds</a></li>
<li class="page_item page-item-6656"><a href="https://www.theonlinerocket.com/comics/">Comics</a></li>
<li class="page_item page-item-7164"><a href="https://www.theonlinerocket.com/feedback/">Contact Us</a></li>
<li class="page_item page-item-9486"><a href="https://www.theonlinerocket.com/contributor-form/">Contributor Form</a></li>
<li class="page_item page-item-27213"><a href="https://www.theonlinerocket.com/the-rocket-awards/">Honors &#038; Awards</a></li>
<li class="page_item page-item-182"><a href="https://www.theonlinerocket.com/pollsarchive/">pollsarchive</a></li>
<li class="page_item page-item-24803"><a href="https://www.theonlinerocket.com/the-rocket-archives/">The Rocket Archives</a></li>
<li class="page_item page-item-9779"><a href="https://www.theonlinerocket.com/job-descriptions/">The Rocket Staff Positions</a></li>
<li class="page_item page-item-24648 page_item_has_children"><a href="https://www.theonlinerocket.com/staff-info/">The Staff Page</a>
<ul class='children'>
	<li class="page_item page-item-24655"><a href="https://www.theonlinerocket.com/staff-info/staff-applications/">2018-2019 Staff Applications</a></li>
</ul>
</li>
</ul></div>
</ul></div><script type="text/javascript">
		$(document).ready(function(){
			

			function sharingIconsResize() {
				if ($(window).width() < 850) {
					var socialwidth;
					var count = $("#mobile-socialmedia .sharing-mobile-show").length;
					if (count != 0) {
						socialwidth = 100 / count;
						$('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
					}
				} else {
					$('#sno_hoverbar .sharing-icon').width('50px');
				}
			}
						
			$('.sno-search-button').click(function() {
				$('#sno_hoversearch').fadeToggle();
				$('#sno_hoversearch').css({ top: '0' });
				$('#s-alt').focus();
			});
			$('.sno-search-close').click(function() {
				$('#sno_hoversearch').fadeToggle();
				$('#sno_hoversearch').css({ top: '-50px' });
			});

			var NavScrollTop		= $(window).scrollTop();
    		
    		if( $('.navbarwrap').length ) {
    			var	TopNavOffset 		= $('.navbarwrap').offset().top;
				var TopNavDistance		= (TopNavOffset - NavScrollTop);
   	 		}
   	 		if( $('.subnavbarwrap').length ) {
	   	 		var	BottomNavOffset 	= $('.subnavbarwrap').offset().top;
	   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
   	 		}
   	 		
   	 		$('#hoverbar_menu .mobile-menu').height( $(window).height() - 50);
   	 		
   	 		var HoverOffset = 0, HoverOffset2 = 0;
			   	 		var HoverHeight = $('#sno_hoverbar').outerHeight();
   	 		var HoverHeight2 = $('#sno_hoverbar').outerHeight();
   	 		
			
			var CurrentScroll = 0;
			var WindowHeight = $(document).height() - $('.footerwrap').height();
			
							WindowHeight -= $('#commentswrap').height();		
						
			
			$('.sno-menu').click(function() {
			
				$('#hoverbar_menu').fadeToggle();
				$('.menu-icon').toggle();
				$('.close-icon').toggle();
				$('#hoverbar_menu').css({ height: $(window).height() - 50 });
			
			});
			
			$(window).scroll(function(event) {
				var NextScroll = $(this).scrollTop();

				var ScrollPercent = (NextScroll / (WindowHeight - $(window).height())) * 100;
				

				$('#progress-bar-color').css({ width: ScrollPercent + '%'});
				$('#hoverbar_menu').css({ top: $('#sno_hoverbar').height() });
				
				if ( ScrollPercent > 100 ) {
										$('.sno-arrow-up').css({ background: '#006F51', color: '#eee'});
					$('.sno-menu').css({ background: '#006F51', color: '#eee'});
					$('.socialmedia .sharing-icon').css({ opacity: 1 })
					
					
				} else {
										$('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
					$('.sno-menu').css({ background: '#eee', color: '#ccc'});
				}
				var headerLocation = $("#wrap").offset().top;
				if (NextScroll > CurrentScroll && $(document).scrollTop() > headerLocation) {
					if ($('#sno_hoverbar').is(":hidden")) {
						$('#sno_hoverbar').show();
						$('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
						
												
													var lpb = $('.lf_headerleft').width();
							lpb += $('#sno_hoverbar .sno-menu').width(); 							var rpb = 50 + $('.socialmedia').width();
															rpb += $('#sno_hoverbar .sno-search-button').width();
														$('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
						        			}


        			
				} else if (NextScroll < CurrentScroll && $(document).scrollTop() < ( headerLocation + 300 ) && $('#sno_hoverbar').is(":visible")) {
				
						$('#hoverbar_menu').hide();
						$('.close-icon').hide();
						$('.menu-icon').show();
						$('#hoverbar_menu').hide();
						$('#sno_hoverbar').stop().animate({
							top: '-50px'
							},300, function(){
								$('#sno_hoverbar').hide();
							});
						if ( $('.navbarwrap').length ) { $('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
						if ( $('.subnavbarwrap').length ) { $('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }

				}
			CurrentScroll = NextScroll;
			});


		});

		$("#snotop").hide();
	
		$(function () {
			$(window).scroll(function () {
				if ($(this).scrollTop() > 500) {
					$('#snotop').fadeIn();
				} else {
					$('#snotop').fadeOut();
				}
			});

			$('#back-top a').click(function () {
				$('body,html').animate({
					scrollTop: 0
				}, 800);
				return false;
			});

		});
	</script></body></html>